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BAB 7 

MOVIE INTERAKTIF 

MENGGUNAKAN BEHAVIORS 

DAN ACTIONSCRIPT 

 
Pada animasi-animasi yang telah kita pelajari sebelumnya, animasi 
dijalankan secara berurutan dari frame ke frame berikutnya. Dengan 
adanya Behaviors dan Actionscript, animasi dapat dibuat menjadi 
movie yang interaktif sehingga pengguna dapat berperan lebih aktif 
menggunakan keyboard dan mouse untuk melompat ke movie lain 
yang diinginkannya, memindahkan objek, memasukkan informasi 
pada form, mengontrol objek, video, suara, dan lain-lain. 

Pada bagian ini, kita akan langsung mengimplementasikan Behaviors 
dan ActionScript dalam bentuk tutorial dan latihan. Dengan 
mencobanya pada contoh aplikasinya langsung, pembaca 
memperoleh dasar yang baik untuk memahami dan memudahkan 
penguasaan Behaviors dan ActionScript. 

7.1 Menggunakan Behaviors 
Behaviors juga termasuk salah satu fitur baru yang sangat menonjol 
di Flash MX 2004. Behaviors merupakan ActionScript siap pakai yang 
dapat diaplikasikan pada suatu objek, baik itu movie clip, video 
maupun suara (sound). Fungsi utamanya ialah untuk mengontrol 
objek-objek tersebut agar terlihat lebih fleksibel dan interaktif. 
Asyiknya lagi, semua itu dilakukan secara otomatis tanpa kita perlu 
menuliskan kode-kode ActionScript secara manual. 
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Behaviors lebih ditujukan untuk para developer Flash yang belum 
terbiasa/familiar dengan ActionScript karena Behaviors telah 
menyederhanakan fungsi-fungsi ActionScript yang kompleks sehingga 
dapat diaplikasikan dengan mudah pada objek, video, suara, dan 
frame. 

Untuk menampilkan Behaviors Panel, klik menu Window > 
Development Panels > Behaviors. Lihat Gambar 7.1. 

 

Gambar 7.1 Behaviors Panel 

Kalau kita perhatikan pada Gambar 7.1, Behaviors Panel terlihat 
sangat sederhana karena memang diperuntukkan bagi pengguna 
pemula. Apabila kita ingin memasukkan suatu Action, kita hanya 
perlu mengklik tombol , maka akan tampil menu pilihannya, lalu 
kita tinggal memilih kategori dan action yang diinginkan. Untuk lebih 
jelasnya, langsung saja kita praktekkan ya. 

7.1.1 Membuat Tombol Link 

Tombol link adalah tombol yang digunakan untuk memanggil alamat 
atau URL di Internet, misalnya akan memanggil situs Google atau 
bisa juga untuk berpindah ke halaman web lainnya ketika tombol 
diklik. 

1. Masukkan sebuah tombol dari library Flash (Window > Other 
Panels > Common Libraries > Buttons). Latihan ini 
menggunakan tombol arcade button-yellow dari kategori 
Arcade buttons. Lihat Gambar 7.2. 
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Gambar 7.2 Tombol arcade button - yellow 

2. Klik/pilih pada tombol, lalu klik tanda  pada Behaviors Panel 
sehingga akan tampil menu. Pilihlah Web > Go to Web Page. 
Lihat Gambar 7.3. 

 

Gambar 7.3 Memilih action Go to Web Page pada kategori Web 

3. Akan tampil kotak dialog. Isikan http://www.google.com pada 
URL dan pilih “_blank” pada Open in. Lihat Gambar 7.4. 

 

Gambar 7.4 Kotak dialog Go to URL 

Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
tombol berwarna kuning yang akan langsung membuka browser baru 
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(Internet Explorer) dan menampilkan halaman web dari situs Google 
apabila komputer Anda terhubung ke Internet.  

Tip & Trik: 

 Selain dapat memanggil alamat URL di Internet, link juga dapat 
digunakan untuk berpindah halaman, contohnya halaman2.html 
atau /data/halaman2.html (kalau filenya di dalam suatu 
subfolder). Link juga bisa digunakan untuk memanggil email, 
misalnya mailto: algosigma@eudoramail.com. Link juga dapat 
memanggil suatu movie, misalnya animasi.swf. 

 Link mempunyai parameter Open in yang berisi target untuk link 
tersebut. Ada empat macam target, yaitu: 

 _self: link akan membuka file yang dipanggil di halaman itu 
juga. 

 _blank: link akan membuka file yang dipanggil pada 
halaman/browser yang baru. 

 _parent: link akan membuka file yang dipanggil di frameset 
induk (digunakan untuk halaman berbentuk frame, sama 
halnya dengan _top). 

 _top: link akan membuka file yang dipanggil di frameset 
pada tingkat yang paling atas. 

7.1.2 Memanggil File Movie di Luar Flash 

Action untuk memanggil file movie yang berada di luar Flash adalah 
Load External Movieclip di kategori Movieclip.  

Pada latihan ini, kita akan memanggil file shockwave dengan nama 
joke.swf yang berisi animasi kartun lucu. 

1. Buat file baru (File > New), lalu langsung simpan filenya (File > 
Save As), misalnya disimpan dengan nama loadswf.fla. 

2. Klik frame 1, lalu klik tanda  pada Behaviors Panel sehingga 
akan tampil menu. Pilihlah Movieclip > Load External 
Movieclip. Lihat Gambar 7.5. 
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Gambar 7.5 Memilih action Load External Movieclip pada kategori 
Movieclip 

3. Akan tampil sebuah kotak dialog. Isikan nama file swf 
(shockwave) yang akan dipanggil pada bagian Type the URL to 
the .swf file you want to load, misalnya joke.swf. Lihat 
Gambar 7.6. 

 

Gambar 7.6 Kotak dialog Load External Movieclip 

4. Sekarang di Timeline Panel dapat dilihat bahwa pada frame 1 
terdapat huruf a yang menandakan bahwa pada frame tersebut 
terdapat action/behavior. Lihat Gambar 7.7. 
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Gambar 7.7 Tanda huruf a pada frame 1 di Timeline Panel 

Untuk melihat hasilnya, klik menu Control > Test Movie. Akan 
langsung ditampilkan movie swf (shockwave) yang berupa animasi 
kartun lucu. Lihat Gambar 7.8. 

 

Gambar 7.8 Hasil action Load External Movieclip 

Catatan:  

File joke.swf harus berada dalam satu folder dengan file loadswf.fla 
(file yang berisi action untuk memanggil movie tersebut/file 
joke.swf). 

7.1.3 Menggandakan Objek 

Action untuk menggandakan suatu objek atau gambar adalah 
Duplicate Movieclip dari kategori Movieclip.  
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Pada latihan ini, kita akan menggandakan gambar seorang wanita 
yang sedang menelpon. 

1. Klik menu File > Import > Import to Stage, lalu carilah sebuah 
file gambar, dalam latihan ini gambar wanita yang sedang 
menelpon (wanita1.jpg). Lihat Gambar 7.9. 

 

Gambar 7.9 Gambar wanita sedang menelpon 

2. Klik/pilih pada gambar wanita, lalu ubah menjadi simbol Movie 
clip. 

3. Dengan gambar wanita masih dalam keadaan terpilih, isikan 
nama pada Properties sebagai identitas movie clip tersebut, 
misalnya wanita. Lihat Gambar 7.10. 

 

Gambar 7.10 Memberi nama identitas dari movie clip 

4. Dengan gambar wanita masih dalam keadaan terpilih, klik tanda 
 pada Behaviors Panel sehingga akan tampil menu. Pilihlah 

Movieclip > Duplicate Movieclip. Lihat Gambar 7.11. 
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Gambar 7.11 Memilih action Duplicate Movieclip pada kategori 
Movieclip 

5. Akan tampil kotak dialognya. Isikan 110 pada bagian X-offset dan 
0 pada Y-offset. Lihat Gambar 7.12. 

 

Gambar 7.12 Kotak dialog Duplicate Movieclip 

Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
pada gambar wanita. Akan tampil gambar wanita yang sama di 
samping kanannya, lalu klik lagi gambar wanita sehingga akan tampil 
gambar wanita yang sama di samping kanannya lagi, begitu 
seterusnya. Lihat Gambar 7.13. 
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Gambar 7.13 Hasil penggandaaan suatu gambar menggunakan action 
duplicate movie 

7.1.4 Drag ‘n Drop pada Objek  

Kalau Anda sudah sering menggunakan mouse, tentunya Anda sudah 
mengenal istilah drag and drop, yaitu proses memindahkan objek 
menggunakan mouse (klik dan tahan), lalu menyeret (drag) untuk 
meletakkannya ke tempat yang diinginkan. 

Pada latihan ini, kita akan membuat sebuah objek/gambar yang 
dapat dipindahkan menggunakan mouse, dan meletakkannya di 
tempat yang diinginkan. 

1. Imporlah sebuah gambar; latihan ini menggunakan gambar 
binaragawan yang sedang memamerkan ototnya 
(binaragawan.wmf). Lihat Gambar 7.14. 

 

Gambar 7.14 Gambar binaragawan yang sedang memamerkan ototnya 
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2. Klik/pilih pada gambar binaragawan, lalu ubah menjadi simbol 
Movie clip. 

3. Dengan gambar binaragawan masih dalam keadaan terpilih, 
isikan identitas movie clip tersebut pada Properties, misalnya 
binaraga (untuk caranya, lihat lagi Gambar 7.10). 

4. Dengan gambar binaragawan masih dalam keadaan terpilih, klik 
tanda  pada Behaviors Panel sehingga akan tampil menu. 
Pilihlah Movieclip > Start Dragging Movieclip pada menu 
tersebut. Lihat Gambar 7.15. 

 

Gambar 7.15 Memilih action Start Dragging Movieclip pada kategori 
Movieclip 

5. Pada kotak dialog yang tampil, klik OK. Lihat Gambar 7.16. 

 

Gambar 7.16 Kotak dialog Start Dragging Movieclip 
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6. Pada Behaviors Panel, klik tanda panah ke bawah  yang 
terdapat di samping kanan Event On Release sehingga akan 
tampil pilihannya. Gantilah event-nya dengan memilih Event On 
Press. Lihat Gambar 7.17. 

 

Gambar 7.17 Mengganti suatu Event 

7. Masih di Behaviors Panel, klik tanda  sehingga akan tampil 
menu. Pilihlah Movieclip > Stop Dragging Movieclip, maka akan 
tampil kotak dialognya. Klik OK saja. Lihat Gambar 7.18. 

 

Gambar 7.18 Kotak dialog Stop Dragging Movieclip 

8. Sekarang di Behaviors Panel terdapat dua perintah, yaitu Event 
On Press dengan Action Start Dragging Movieclip dan Event On 
Release dengan Action Stop Dragging Movieclip. Lihat 
Gambar 7.19. 

 

Gambar 7.19 Dua action di Behaviors Panel 
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Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
pada gambar binaragawan, lalu drag ke tempat manapun yang Anda 
inginkan. 

Keterangan Action: 

Event-event Mouse/Keyboard, yaitu:  

 Press: Keadaan ketika kursor mouse berada di atas tombol dan 
mouse sedang ditekan. 

 Release: Keadaan ketika kursor mouse berada di atas tombol 
dan mouse sudah ditekan dan dilepaskan (hampir sama dengan 
Press). 

 Release Outside: Keadaan ketika kursor mouse berada di atas 
tombol dan mouse sudah ditekan dan dilepaskan di luar area 
tombol. 

 Key Press: Keadaan ketika tombol keyboard ditekan, jadi 
mendeteksi penekanan tombol di keyboard. 

 Roll Over: Keadaan ketika kursor mouse berada di atas tombol. 

 Roll Out: Keadaan ketika kursor mouse bergerak ke luar dari 
area tombol. 

 Drag Over: Keadaan ketika kursor mouse berada di atas tombol 
dan mouse sudah ditekan, kemudian kursor bergerak ke luar area 
tombol, lalu kembali lagi sambil mouse tetap ditekan. 

 Drag Out: Keadaan ketika kursor mouse berada di atas tombol 
dan mouse sudah ditekan, kemudian kursor bergerak keluar area 
tombol. 

 startDrag berfungsi untuk membuat movie klip mengikuti 
gerakan pointer mouse. 

 stopDrag merupakan kebalikan dari action startDrag. 

7.1.5 Memanggil (Load) Suara dari Library Flash 

Action untuk memanggil (load) suara dari library Flash adalah Load 
Sound from Library dari kategori Sound. 

Pada latihan ini, kita akan memanggil suara harimau dari library 
Flash. 
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1. Masukkan dua buah tombol dari library Flash. Latihan ini 
menggunakan tombol gel Right dan gel Stop dari kategori 
Playback. Lihat Gambar 7.20. 

 

Gambar 7.20 Memasukkan tombol gel Right dan gel Stop 

2. Klik menu File > Import > Import to Stage, lalu carilah sebuah 
file suara, dalam latihan ini digunakan suara harimau 
(harimau.wav). 

3. Klik menu Window > Library untuk menampilkan Library Panel, 
maka di dalamnya sudah terdapat file suara yang telah diimpor. 
Klik kanan pada suara harimau di library, lalu pilih Linkage. 

 

Gambar 7.21 Memberikan Linkage pada suara harimau 
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4. Akan tampil kotak dialognya. Isikan aum pada Identifier dan 
berikan tanda centang ( ) pada Export for ActionScript. Lihat 
Gambar 7.22. 

 

Gambar 7.22 Kotak dialog Linkage Properties 

5. Di Library Panel, suara harimau mempunyai Linkage dengan 
nama aum. Lihat Gambar 7.23. 

 

Gambar 7.23 Linkage dengan nama aum 

6. Sekarang klik/pilih tombol play (tombol di kiri), lalu klik tanda  
pada Behaviors Panel sehingga akan tampil menu. Pilihlah Sound 
> Load Sound from Library dari menu tersebut. Lihat 
Gambar 7.24. 
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Gambar 7.24 Memilih action Load Sound from Library pada kategori 
Sound 

7. Akan tampil kotak dialognya. Isikan seperti pada Gambar 7.25. 

 

Gambar 7.25 Kotak dialog Load Sound from Library 

8. Klik/pilih tombol stop (tombol di kanan), lalu klik tanda  pada 
Behaviors Panel. Akan tampil menu, lalu pilihlah Sound > Stop 
Sound sehingga akan tampil kotak dialog. Isikan seperti pada 
Gambar 7.26. 
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Gambar 7.26 Kotak dialog Stop Sound 

Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
pada tombol play, maka akan terdengar suara harimau. Untuk 
menghentikan suara tersebut, klik tombol stop. 

7.1.6 Memanggil Suara dari File Streaming MP3 

Action untuk memanggil (load) suara dari file MP3 adalah Load 
streaming MP3 file dari kategori Sound.  

Pada latihan ini, kita akan memanggil suara/lagu “cindai” Siti 
Nurhaliza yang merupakan lagu dengan format MP3. 

1. Masukkan dua buah tombol dari library Flash. Pada latihan ini 
menggunakan tombol playback-play dan playback-stop dari 
kategori Playback. Lihat Gambar 7.27. 

 

Gambar 7.27 Memasukkan tombol playback-play dan playback-stop 

2. Klik/pilih tombol play (tombol di sebelah kiri), lalu klik tanda  
pada Behaviors Panel sehingga akan tampil menu. Pilihlah Sound 
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> Load streaming MP3 file, maka akan tampil kotak dialog. 
Isikan seperti pada Gambar 7.28. 

 

Gambar 7.28 Kotak dialog Load streaming MP3 file 

3. Klik/pilih tombol stop (tombol di sebelah kanan), lalu klik tanda 
 pada Behaviors Panel sehingga akan tampil menu. Pilihlah 

Sound > Stop Sound, maka akan tampil kotak dialognya. Isikan 
seperti pada Gambar 7.29. 

 

Gambar 7.29 Kotak dialog Stop Sound 

7.2 Menggunakan ActionScript 
Untuk keperluan interaktif yang sederhana atau standar, kita bisa 
menggunakan Behaviors seperti yang telah kita pelajari pada 
Subbab 7.1. Akan tetapi, untuk keperluan interaktif yang lebih 
kompleks, kita harus menggunakan ActionScript. 

ActionScript bisa disebut dengan bahasa pemrogramannya Flash. 
Dengan ActionScript, kita bisa membuat movie yang interaktif 
sehingga user bisa berinteraksi dengan movie tersebut, seperti 
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mengontrol navigasi, memasukkan informasi, menggerakkan objek 
dengan keyboard, mengubah bentuk mouse, membuat menu, games, 
kuis, dan lain-lain. 

ActionScript atau Action dibagi menjadi dua, yaitu:  

 Action Frame adalah Action yang diberikan pada frame. Frame 
yang berisi Action ditandai dengan huruf a pada framenya. Lihat 
Gambar 5.91. 

 Action Objek adalah Action yang diberikan pada objek, baik 
berupa tombol maupun movie clip. 

Catatan: 

ActionScript di Flash sangatlah luas dan banyak cakupannya, apalagi 
ActionScript di Flash MX 2004 yang sudah mendukung ActionScript 
v2. Oleh karena itu, pada bagian ini penulis hanya membahas cara 
penggunaan action-action dasar saja.  

Rencananya sih mau bikin buku tersendiri yang membahas full 
ActionScript dari pemula sampai tingkat mahir, tunggu aja tanggal 
mainnya, tapi nggak janji lho. 

7.2.1 Mengenal Area Kerja ActionScript  

ActionScript mempunyai panel di mana di dalamnya kita bisa 
memberikan dan mengatur action. Untuk menampilkannya, klik 
menu Window > Development Panels > Actions. Lihat Gambar 7.30. 

Keterangan Gambar 7.30: 

 Actions category, menunjukkan action diberikan pada frame 
atau pada objek (button atau movie clip). 

 Actions toolbox, berisi kumpulan ActionScript yang disediakan 
oleh Flash dan dapat dipakai langsung dengan melakukan klik 
ganda pada action yang diinginkan. 

 Script navigator, menampilkan lokasi di file FLA yang 
dihubungkan ke ActionScript. Di sini kita bisa menjelajahi 
melalui file FLA untuk menemukan kode ActionScript. 

 Script pane, merupakan tempat dituliskannya/ditempatkannya 
kode-kode dari ActionScript. 
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 Popup-menu, berisi kumpulan perintah untuk mengatur Actions 
Panel. 

 

Gambar 7.30 Actions Panel 

Kalau kita lihat lagi pada Gambar 7.30, di bagian atas Script pane 
terdapat beberapa tombol yang nantinya berguna untuk membantu 
penulisan script/kode di area Script pane. Keterangan detil fungsi 
masing-masing tombol dapat dilihat pada Gambar 7.31. 

 

Gambar 7.31 Tombol-tombol di atas area Script pane 
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Keterangan Gambar 7.31: 

 Add item to script, untuk memasukkan kode ActionScript ke 
Script pane (selain melalui Actions toolbox). 

 Find, untuk mencari atau menemukan suatu kode dalam Script 
pane. 

 Replace, untuk mengganti suatu kode yang telah ditemukan 
tombol Find. 

 Target path, untuk mencari target/sasaran objek, biasanya 
berupa movie clip. 

 Check Syntax, untuk melakukan cek/pemeriksaan kesalahan 
pada sintaks kode yang dituliskan di Script pane. 

 Auto Format, untuk merapikan tampilan kode di Script pane. 

 Show Code Hint, untuk menampilkan penunjuk kode untuk 
action yang akan digunakan. 

 Reference, untuk menampilkan referensi dari ActionScript yang 
berisi keterangan-keterangan dan contoh-contoh penggunaan 
dari ActionScript. 

 Debug Options, untuk menandai suatu kode yang salah. 

 View Options pop-up menu, ada tiga pilihan di dalamnya, yaitu 
View Esc Shortcut Keys (untuk menampilkan tombol singkat Esc 
untuk semua ActionScript di Action toolbox), View Line Numbers 
(untuk menampilkan nomor baris kode pada Script pane), Word 
Wrap (apabila kode yang dituliskan pada Script pane terlalu 
panjang maka akan diletakkan di baris berikutnya secara 
otomatis tanpa kita tekan tombol Enter di keyboard). 

7.2.2 Action untuk Menghentikan Movie  

Secara standar, movie/animasi yang dibuat dengan Flash akan 
menghasilkan animasi yang berulang-ulang sampai Anda menutup 
jendela tempat animasi dimainkan. Akan tetapi terkadang hal 
tersebut membuat kita bosan atau mengganggu tampilan animasi 
yang lain.  
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Sekarang timbul pertanyaan, apakah bisa menghentikan animasi 
ketika animasinya sudah selesai? Tentu saja bisa, tambahkan saja 
action stop di frame terakhir. 

Pada latihan ini, kita akan menghentikan animasi kecelakaan 
pesawat yang telah kita buat pada Subbab 4.4. 

1. Klik menu File > Open, lalu cari dan buka file animasi 
kecelakaan pesawat.fla. Lihat Gambar 7.32. 

 

Gambar 7.32 File animasi kecelakaan pesawat 

2. Klik pada frame terakhir dari animasi pesawat, yaitu frame 40. 

3. Kemudian klik menu Window > Development Panels > Actions 
untuk menampilkan Actions Panel. Bagian Actions Category 
berlabel Actions-Frame yang menandakan bahwa kita akan 
memberikan action pada Frame. Lihat Gambar 7.33. 

 

Gambar 7.33 Action stop diberikan pada frame 
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4. Pada Actions toolbox, klik pada bagian Global Functions, lalu 
klik lagi bagian Timeline Control untuk menampilkan kumpulan 
Action di dalamnya, kemudian klik dua kali action stop sehingga 
secara otomatis di Script pane akan tertulis kode stop( );. Lihat 
lagi Gambar 7.33. 

5. Sekarang dapat dilihat bahwa pada Timeline Panel di frame 40 
terdapat huruf a yang menandakan terdapat action pada frame 
tersebut. Lihat Gambar 7.34. 

 

Gambar 7.34 Tanda action pada frame 40 

Untuk melihat hasilnya, klik menu Control > Test Movie sehingga 
animasi kecelakaan pesawat akan berhenti saat animasinya sudah 
selesai, berbeda dengan sebelumnya di mana animasi akan berulang-
ulang terus tanpa henti. 

7.2.3 Action untuk Mengontrol Animasi 

Kita bisa mengontrol suatu animasi yang sedang dimainkan, misalnya 
menghentikan animasi tersebut saat gerakannya berada di tengah 
layar, kemudian memainkannya lagi. Action yang digunakan dalam 
kasus tersebut adalah action play dan stop.  

Pada latihan ini, kita akan mengontrol animasi bola memantul yang 
telah kita buat pada Subbab 4.5. 

1. Bukalah file animasi bola memantul.fla. Lihat Gambar 7.35. 

2. Klik menu Insert > Timeline > Layer untuk menambahkan layer 
baru (Layer 2). Pada Layer 2, masukkan dua buah tombol dari 
library Flash (Window > Other Panels > Common Libraries > 
Buttons). Latihan ini menggunakan tombol stop dan play dari 
kategori Circle Buttons. Lihat Gambar 7.36. 
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Gambar 7.35 File animasi bola memantul 

 

Gambar 7.36 Memasukkan tombol stop dan play 

3. Klik/pilih tombol stop, lalu buka Actions Panel. Bagian Actions 
Category berlabel Actions–Button yang menandakan bahwa kita 
akan memberikan action pada tombol/button. Lihat 
Gambar 7.37. 
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Gambar 7.37 Action on diberikan pada tombol/button 

4. Pada bagian Action toolbox, klik pada bagian Global Functions, 
lalu klik lagi bagian Movie Clip Control untuk menampilkan 
kumpulan Action di dalamnya. Kemudian, klik ganda action on 
sehingga pada Script pane akan tertulis kode on( ), dan Code 
Hints dari kode on juga akan tampil. Pilihlah release. Lihat lagi 
Gambar 7.37. 

5. Pada Script pane, letakkan kursor mouse di antara kurung 
kurawal kode on (release). Lihat Gambar 7.38. 

 

Gambar 7.38 Meletakkan kursor di antara tanda kurung kurawal kode 
on (release) 
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6. Berikan Action stop (untuk caranya, lihat Subbab 7.2.2 
langkah (4)). Sekarang kode di Script pane terlihat seperti pada 
Gambar 7.39. 

 

Gambar 7.39 Hasil pemberian Action stop di dalam kode on (release) 

7. Selanjutnya, klik/pilih tombol play, lalu berikan Action on 
dengan Code Hints release (untuk caranya, lihat langkah 3). 
Berikan action play yang terdapat di bagian Timeline Control 
sehingga terbentuklah kode pada Script pane seperti terlihat 
pada Gambar 7.40. 

 

Gambar 7.40 Hasil pemberian Action play di dalam kode on (release) 
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Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
tombol stop agar animasi akan berhenti. Untuk memainkan animasi 
lagi, klik tombol play. 

Keterangan Action: 

 stop berfungsi untuk menghentikan movie atau animasi.  

 play berfungsi untuk memainkan movie atau animasi. 

7.2.4 Action untuk Navigasi antar Frame Label 

Navigasi berfungsi untuk membawa pengunjung menjelajah dari satu 
halaman ke halaman lainnya melalui media link, tombol, atau menu.  

Navigasi dalam Flash dapat dilakukan dengan berbagai cara, seperti 
navigasi antar-frame, navigasi antar-scene, navigasi antar-movie, 
dan navigasi melalui URL. Akan tetapi, cara terbaik di antara 
keempat cara tersebut adalah navigasi antar-frame karena ukuran 
file yang dihasilkan paling kecil sehingga akan mempengaruhi 
kecepatan loading yang diutamakan dalam sebuah situs web. 

Pada latihan ini, kita akan membuat navigasi antar-frame label 
(frame yang diberi label/nama) menggunakan action gotoAndStop. 

1. Klik Text Tool lalu tulislah teks “Halaman Home” di layar. Lihat 
Gambar 7.41. 

 

Gambar 7.41 Teks Halaman Home di tengah layar 

2. Klik frame 15, lalu klik menu Insert > Timeline > Blank 
Keyframe. Pada frame 15, tulislah teks “Halaman Profil”. Lihat 
Gambar 7.42. 
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Gambar 7.42 Teks Halaman Profil di tengah layar 

3. Klik frame 1, lalu berilah nama/label “home” pada frame 
tersebut melalui Properties-nya. Lihat Gambar 7.43. 

 

Gambar 7.43 Cara memberi label pada frame 

4. Lakukan hal yang sama untuk frame 15 dengan memberinya label 
“profil” sehingga sekarang ada dua label di frame, yaitu “home” 
di frame 1 dan “profil” di frame 15. Lihat Gambar 7.44. 

 

Gambar 7.44 Dua label di frame 
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5. Masukkan layer baru (Layer 2). Pada Layer 2, masukkan dua buah 
tombol dari library Flash. Latihan ini menggunakan tombol circle 
button - previous dan circle button - next dari kategori Circle 
Buttons. Lihat Gambar 7.45. 

 

Gambar 7.45 Memasukkan tombol circle button - previous dan circle 
button - next 

6. Klik/pilih tombol circle button - next (tombol di sebelah kanan), 
lalu berikan Actions on (untuk caranya, lihat Subbab 7.2.3 
langkah (4) hingga (5)), kemudian berikan action gotoAndStop di 
antara tanda kurung kurawal kode on (release) sehingga hasilnya 
terlihat seperti pada Gambar 7.46. 

 

Gambar 7.46 Memberikan action gotoAndStop pada tombol 
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7. Letakkan kursor di dalam kurung kode gotoAndStop, lalu tuliskan 
“profil”. Hal ini bertujuan agar apabila tombol diklik, movie 
akan menuju label profil yang sudah diberikan pada frame 
sehingga kode gotoAndStop akan terlihat seperti pada 
Gambar 7.47. 

 

Gambar 7.47 Memberikan tujuan dari action gotoAndStop 

8. Klik/pilih tombol circle button - previous, lalu ulangi langkah (6) 
hingga (7) sampai terbentuk kode seperti pada Gambar 7.48. 

 

Gambar 7.48 Action gotoAndStop untuk tombol circle button - previous 

9. Klik frame 1 di Layer 2, lalu berikan action stop sehingga movie 
akan langsung berhenti pada frame 1 saat pertama kali 
dijalankan. Timeline Panel yang terbentuk akan terlihat seperti 
pada Gambar 7.49. 
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Gambar 7.49 Timeline Panel untuk navigasi antar frame label 

Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
tombol circle button - next, Anda akan dibawa ke Halaman Profil. 
Coba klik lagi tombol circle button - previous, Anda akan dibawa 
kembali ke halaman semula, yaitu Halaman Home. Cara kerjanya 
mirip link di halaman web. 

Keterangan Action: 

 gotoAndStop berfungsi untuk melompat ke frame tertentu dan 
berhenti di frame tersebut. 

7.2.5 Action untuk Navigasi antar Frame Number 

Bagian ini hampir sama kegunaannya dengan Subbab 7.2.4, hanya 
saja kita tidak akan melakukan navigasi antar-frame label, tetapi 
dengan menyebutkan nomor frame yang dituju. Action yang 
digunakan pun berbeda, yaitu action gotoAndPlay yang akan 
memperindah/memperhalus perpindahan antar-frame/halaman 
karena dapat disertakan animasi saat perpindahannya. 

1. Klik Text Tool, lalu tulislah teks “Halaman Home” di sebelah kiri 
layar. Lihat Gambar 7.50. 

 

Gambar 7.50 Teks Halaman Home di sebelah kiri layar 
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2. Pilih teks, lalu ubah menjadi simbol Graphic. Masukkan 
Keyframe pada frame 15. Pada frame 15, pindahkan teks ke 
tengah layar. Lihat Gambar 7.51. 

 

Gambar 7.51 Teks Halaman Home di tengah layar pada frame 15 

3. Klik frame 1, lalu berikan Tween Motion. Masih di frame 1, 
klik/pilih pada teks, kemudian pilih pada bagian Color: Alpha 0% 
pada Properties-nya. 

4. Buat layer baru (Layer 2). Pada Layer 2, masukkan Blank 
Keyframe pada frame 16. Pada frame 16, tulislah teks ”Halaman 
Produk” di sebelah kanan layar. Lihat Gambar 7.52. 

 

Gambar 7.52 Teks Halaman Produk di sebelah kanan layar 

5. Pilih teks, lalu ubah menjadi simbol Graphic. Masukkan 
Keyframe pada frame 30. Pada frame 30, pindahkan teks ke 
tengah layar. Lihat Gambar 7.53. 
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Gambar 7.53 Teks Halaman Produk di tengah layar pada frame 30 

6. Klik frame 16, lalu berikan Tween Motion. Masih di frame 16, 
klik/pilih pada teks, kemudian pilih bagian Color: Alpha 0% pada 
Properties-nya. 

7. Pada Layer 1, klik frame 15, lalu berikan action stop pada frame 
tersebut. Lakukan hal yang sama pada Layer 2 di frame 30. 
Sekarang frame yang terbentuk di Timeline Panel dapat dilihat 
pada Gambar 7.54. 

 

Gambar 7.54 Action stop di frame 15 dan frame 30 

8. Buat layer baru (Layer 3) dan masukkan dua buah tombol dari 
library Flash. Latihan ini menggunakan tombol playback - step 
forward dan playback - step back dari kategori Playback. Lihat 
Gambar 7.55. 

9. Klik/pilih tombol playback - step forward (tombol di kiri), lalu 
berikan action on dan gotoAndPlay. Isikan nilai frame yang akan 
dituju di dalam kurung action gotoAndPlay, yaitu 16 (frame 16). 
Lihat Gambar 7.56. 
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Gambar 7.55 Memasukkan tombol playback - step forward 
dan playback - step back 

 

Gambar 7.56 Memberikan action gotoAndPlay 16 pada tombol step 
forward 

10. Klik/pilih tombol playback – step back (tombol di kanan), lalu 
berikan action on dan gotoAndPlay. Isikan nilai frame yang akan 
dituju dalam kurung action gotoAndPlay, yaitu 1 (frame 1) 
sehingga terbentuklah kode di Script pane seperti pada 
Gambar 7.57. 

 

Gambar 7.57 Memberikan action gotoAndPlay 1 pada tombol step back 
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Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
tombol playback - step forward, Anda akan dibawa ke Halaman 
Produk. Coba klik lagi tombol playback - step back, Anda akan 
dibawa kembali ke halaman semula, yaitu Halaman Home.  

Sekarang coba Anda bandingkan hasilnya dengan Subbab 7.2.4, pasti 
beda kan? Lebih bagus mana? Pilihan ada di tangan Anda dan 
tentunya setiap orang biasanya punya pilihan dan selera yang 
berbeda. 

Keterangan Action: 

 gotoAndPlay berfungsi untuk melompat ke frame tertentu dan 
memainkan animasi dimulai dari frame tersebut sampai frame 
yang ditentukan. 

7.2.6 Action untuk Mengatur Perilaku Movie Clip 

Pada bagian-bagian sebelumnya, kita sudah mempelajari cara 
memberikan action pada frame dan tombol, tapi ada satu hal yang 
belum kita pelajari, yaitu memberikan action pada movie clip. 
Bagaimana caranya? Ikuti pembahasan berikut ini yang akan 
membahas cara mengatur perilaku movie clip. 

1. Klik Rectangle Tool, lalu gambarlah kotak seperti pada 
Gambar 7.58. 

 

Gambar 7.58 Objek kotak 

2. Klik/pilih kotak tersebut, lalu ubah menjadi simbol Movie clip. 

3. Dengan kotak masih dalam keadaan terpilih, berikan action 
onClipEvent dari kategori Movie Clip Control sehingga akan 
tampil Code Hints-nya, lalu pilihlah mouseDown. Lihat 
Gambar 7.59. 
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Gambar 7.59 Memberikan action onClipEvent pada kotak 

4. Pada Script pane, letakkan kursor mouse di antara kurung 
kurawal kode onClipEvent (mouseDown), lalu berikan action 
setProperty. Lihat Gambar 7.60. 

 

Gambar 7.60 Memberikan action setProperty 

5. Letakkan kursor di dalam tanda kurung kode setProperty dan 
isikan kode seperti pada Gambar 7.61. 

Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
objek kotak. Objek kotak akan berubah bentuknya menjadi lebih 
tinggi. Lihat Gambar 7.62. 
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Gambar 7.61 Mengisikan kode di dalam action setProperty 

 

Gambar 7.62 Hasil perubahan bentuk pada objek kotak 

Keterangan Action: 

Event-event Movie clip, yaitu:  

 Load: Keadaan ketika movie klip dibaca di timeline atau saat 
movie klip pertama kali dijalankan. 

 EnterFrame: Keadaan ketika setiap frame movie klip dimainkan. 

 Unload: Keadaan ketika movie klik dihapus di timeline. 

 Mouse down: Keadaan ketika tombol kiri mouse ditekan. 

 Mouse up: Keadaan ketika tombol mouse dilepaskan. 

 Mouse move: Keadaan ketika mouse digerakkan. 

 Key down: Keadaan ketika tombol keyboard ditekan. 

 Key up: Keadaan ketika tombol keyboard dilepaskan. 

 Data: Keadaan ketika data movie swf dibaca ke dalam movie 
Flash. 
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 setProperty berfungsi untuk mendefinisikan suatu nilai bagi 
properti movie klip. setProperty mempunyai beberapa pilihan 
property, yaitu: 

 _alpha: Menentukan nilai transparansi movie klip.  

 _focusrect: Menentukan apakah tanda kotak akan muncul 
saat navigasi. 

 _height: Mengubah tinggi movie klip. 

 _highquality: Mengubah ketajaman objek dari movie klip. 

 _name: Memberikan nama baru pada movie klip. 

 _quality: Mengubah ketajaman objek dari movie klip secara 
keseluruhan. 

 _rotation: Memutar movie klip. 

 _soundbuftime: Menentukan waktu pada movie klip untuk 
memulai suara. 

 _visibile: Menentukan apakah movie klip terlihat atau tidak. 

 _width: Mengubah lebar movie klip. 

 _x: Mengubah posisi horisontal movie klip. 

 _xscale: Mengubah dimensi horisontal movie klip. 

 _y: Mengubah posisi vertikal movie klip. 

 _yscale: Mengubah dimensi vertikal movie klip. 

7.2.7 Action Untuk Menampilkan dan 
Menyembunyikan Movie Clip 

Berikut ini kita akan sedikit mengembangkan penggunaan action di 
mana nantinya suatu tombol akan dapat mengontrol movie clip. 

Pada latihan ini, kita akan membuat tombol yang dapat 
menampilkan dan menyembunyikan movie clip. 

1. Imporlah sebuah gambar; latihan ini menggunakan gambar 
kartun pensil (kartun3.wmf). Lihat Gambar 7.63. 

2. Klik/pilih gambar kartun pensil, lalu ubahlah menjadi simbol 
Movie clip. 
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Gambar 7.63 Gambar kartun pensil 

3. Dengan gambar masih dalam keadaan terpilih, isikan namanya 
sebagai pensil pada Properties. Lihat Gambar 7.64. 

 

Gambar 7.64 Memberi nama instance pada movie clip 

4. Masukkan layer baru (Layer 2). Pada Layer 2, masukkan dua buah 
tombol dari library Flash. Latihan ini menggunakan tombol Oval 
buttons - green dan Oval buttons - yellow dari kategori Ovals.  

 

Gambar 7.65 Memasukkan tombol Oval button  green 
dan Oval button-yellow 
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5. Klik/pilih tombol Oval buttons – green (tombol di sebelah kiri), 
lalu berikan Action on (release) dan setProperty. 

6. Letakkan kursor di dalam kurung kode setProperty, lalu klik 
tombol Insert a target path. Lihat Gambar 7.66. 

 

Gambar 7.66 Tombol Insert a target path 

7. Akan tampil kotak dialognya, lalu pilih pensil dan Absolute. 

 

Gambar 7.67 Kotak dialog Insert Target Path 

8. Akan terbentuk kode di dalam kurung kode setProperty seperti 
pada Gambar 7.68. 
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Gambar 7.68 Hasil memasukkan target ke kode setProperty 

9. Lengkapilah kodenya hingga terlihat seperti pada Gambar 7.69. 

 

Gambar 7.69 Menentukan perilaku pada movie clip pensil 

10. Klik/pilih tombol Oval buttons - yellow, lalu berikan action on 
dan setProperty. Ulangilah langkah (6) hingga (9) sampai 
terbentuk kode seperti pada Gambar 7.70. 

 

Gambar 7.70 Action untuk tombol Oval buttons - yellow 
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Untuk melihat hasilnya, klik menu Control > Test Movie. Coba klik 
tombol Oval berwarna hijau (tombol di sebelah kiri) agar gambar 
pensil akan menghilang (visible=0). Untuk menampilkannya kembali, 
klik tombol Oval berwarna kuning (visible=1). 


